Check out what’s new from Firebase at Google I/O 2022. Learn more

Google Play सेवाओं पर Firebase Android SDK की निर्भरता

कुछ फायरबेस एंड्रॉइड एसडीके Google Play सेवाओं पर निर्भर करते हैं, जिसका अर्थ है कि वे केवल Google Play सेवाओं के साथ डिवाइस और एमुलेटर पर चलेंगे। ये फायरबेस एसडीके आपके ऐप को एक सुरक्षित, अप-टू-डेट और लाइटवेट एपीआई प्रदान करने के लिए डिवाइस पर Google Play सेवाओं की पृष्ठभूमि सेवा के साथ संचार करते हैं। कुछ Android डिवाइस, जैसे Amazon Kindle Fire डिवाइस या कुछ क्षेत्रों में बेचे जाने वाले डिवाइस में Google Play सेवाएं इंस्टॉल नहीं होती हैं।

किन Firebase SDK को Google Play सेवाओं की आवश्यकता है?

फायरबेस एसडीके को तीन श्रेणियों में विभाजित किया जा सकता है:

  • आवश्यक प्ले सेवाएं — इन एसडीके को Google Play सेवाओं की आवश्यकता होती है, अन्यथा उनकी कोई कार्यक्षमता नहीं होती है।
  • Play सेवाएं सुझाई गईं — इन SDK के लिए Google Play सेवाओं की पूर्ण कार्यक्षमता की आवश्यकता होती है, लेकिन वे अभी भी Google Play सेवाओं के बिना भी अधिकांश कार्यक्षमता प्रदान करते हैं।
  • प्ले सेवाओं की आवश्यकता नहीं है - इन एसडीकेएस को पूर्ण कार्यक्षमता के लिए Google Play सेवाओं की आवश्यकता नहीं है।

नीचे दी गई तालिकाएं केवल प्रत्येक एसडीके की नवीनतम रिलीज के लिए सटीक हैं। कुछ पुराने संस्करणों में सख्त आवश्यकताएं हो सकती हैं।

Google Play सेवाओं की आवश्यकता नहीं है

उत्पाद पुस्तकालय गूगल प्ले सेवाएं?
ऐप चेक कस्टम और डिबग प्रदाता com.google.firebase:firebase-appcheck:16.0.0
com.google.firebase:firebase-appcheck-debug:16.0.0
आवश्यक नहीं
ऐप वितरण com.google.firebase:firebase-appवितरण:16.0.0-beta02
com.google.firebase:firebase-appdistribution-ktx:16.0.0-beta02
आवश्यक नहीं
प्रमाणीकरण com.google.firebase:firebase-auth:21.0.4
com.google.firebase:firebase-auth-ktx:21.0.4
आवश्यक नहीं
क्लाउड फायरस्टोर com.google.firebase:firebase-firestore:24.1.2
com.google.firebase:firebase-firestore-ktx:24.1.2
आवश्यक नहीं
फायरबेस क्लाइंट एसडीके के लिए क्लाउड फ़ंक्शंस com.google.firebase:firebase-functions:20.1.0
com.google.firebase:firebase-functions-ktx:20.1.0
आवश्यक नहीं
फायरबेस के लिए क्लाउड स्टोरेज com.google.firebase:firebase-storage:20.0.1
com.google.firebase:firebase-storage-ktx:20.0.1
आवश्यक नहीं
क्रैशलिटिक्स com.google.firebase:firebase-crashlytics:18.2.10
com.google.firebase:firebase-crashlytics-ktx:18.2.10
आवश्यक नहीं
इन-ऐप मैसेजिंग com.google.firebase:firebase-inappmessaging:20.1.2
com.google.firebase:firebase-inappmessaging-ktx:20.1.2
आवश्यक नहीं
इन-ऐप मैसेजिंग डिस्प्ले com.google.firebase:firebase-inappmessaging-display:20.1.2
com.google.firebase:firebase-inappmessaging-display-ktx:20.1.2
आवश्यक नहीं
फायरबेस इंस्टॉलेशन com.google.firebase:firebase-स्थापना:17.0.1
com.google.firebase:firebase-installations-ktx:17.0.1
आवश्यक नहीं
निष्पादन की निगरानी com.google.firebase:firebase-perf:20.0.6
com.google.firebase:firebase-perf-ktx:20.0.6
आवश्यक नहीं
रीयलटाइम डेटाबेस com.google.firebase:firebase-डेटाबेस:20.0.5
com.google.firebase:firebase-database-ktx:20.0.5
आवश्यक नहीं
रिमोट कॉन्फिग com.google.firebase:firebase-config:21.1.0
com.google.firebase:firebase-config-ktx:21.1.0
आवश्यक नहीं
उत्पाद पुस्तकालय गूगल प्ले सेवाएं?
AdMob com.google.android.gms:play-services-ads:20.6.0 अनुशंसित*
एनालिटिक्स com.google.firebase:firebase-analytics:21.0.0
com.google.firebase:firebase-analytics-ktx:21.0.0
अनुशंसित*
ऐप चेक प्ले इंटीग्रिटी प्रोवाइडर com.google.firebase:firebase-appcheck-playintegrity:16.0.0 आवश्यक
ऐप चेक सेफ्टीनेट प्रदाता com.google.firebase:firebase-appcheck-safetynet:16.0.0 आवश्यक
ऐप इंडेक्सिंग com.google.firebase:firebase-appindexing:20.0.0 आवश्यक
क्लाउड मैसेजिंग com.google.firebase:firebase-messaging:23.0.5
com.google.firebase:firebase-messaging-ktx:23.0.5
आवश्यक
गतिशील लिंक com.google.firebase:firebase-dynamic-links:21.0.1
com.google.firebase:firebase-dynamic-links-ktx:21.0.1
आवश्यक
फायरबेस एमएल विजन com.google.firebase:firebase-ml-vision:24.1.0 आवश्यक
फायरबेस एमएल कस्टम मॉडल com.google.firebase:firebase-एमएल-मॉडल-दुभाषिया:22.0.4 आवश्यक

* Google Analytics के लिए Firebase SDK किसी भी डिवाइस पर ईवेंट भेज सकता है, लेकिन कुछ स्वचालित जानकारी जैसे जनसांख्यिकी केवल Google Play सेवाओं वाले डिवाइस पर ही उपलब्ध हैं।