Catch up on everthing we announced at this year's Firebase Summit. Learn more

Menginstal Firebase dengan Swift Package Manager

Dimulai dengan Firebase platform Apple SDK versi v8.0.0, dukungan Swift Package Manager Firebase sudah tidak dalam versi beta dan umumnya tersedia untuk digunakan. CocoaPods tidak diperlukan untuk pengguna Swift Package Manager.

Melalui Xcode

Dukungan Swift Package Manager memerlukan Xcode 12.5 atau versi yang lebih tinggi.

  1. Jika bermigrasi dari project berbasis CocoaPods, jalankan pod deintegrate untuk menghapus CocoaPods dari project Xcode Anda. File .xcworkspace yang dihasilkan CocoaPods dapat dihapus dengan aman setelahnya. Jika menambahkan Firebase ke project untuk pertama kalinya, Anda dapat mengabaikan langkah ini.

  2. Di Xcode, instal library Firebase dengan membuka File > Swift Packages > Tambahkan Dependensi Paket…

  3. Pada perintah yang muncul, pilih repositori GitHub Firebase:

    https://github.com/firebase/firebase-ios-sdk.git
    
  4. Pilih versi Firebase yang ingin Anda gunakan. Untuk project baru, sebaiknya gunakan versi terbaru Firebase.

  5. Pilih produk Firebase yang ingin Anda sertakan dalam aplikasi.

Setelah selesai, Xcode akan mulai menyelesaikan dependensi paket Anda dan mendownloadnya di latar belakang.

Melalui Package.swift

Untuk mengintegrasikan Firebase ke paket Swift melalui manifes Package.swift, Anda dapat menambahkan Firebase ke array dependencies pada paket Anda. Untuk mengetahui detail selengkapnya, lihat dokumentasi Swift Package Manager.

dependencies: [

  .package(name: "Firebase",
           url: "https://github.com/firebase/firebase-ios-sdk.git",
           from: "8.0"),
  // ...

],

Selanjutnya, pada setiap target yang bergantung pada produk Firebase, tambahkan ke array dependencies pada target tersebut.

.target(
  name: "MyTargetName",
  dependencies: [
    .product(name: "FirebaseAuth", package: "Firebase"),
    // ...
  ]
),

Pertimbangan khusus produk

Beberapa produk Firebase memerlukan langkah integrasi tambahan agar dapat berfungsi dengan benar.

Google Analytics

Google Analytics memerlukan penambahan flag linker -ObjC ke setelan build target Anda.

Crashlytics

Crashlytics mengharuskan Anda mengupload simbol debug.

Anda dapat menggunakan skrip jalankan agar Xcode mengupload simbol debug secara otomatis setelah proses build. Temukan skrip jalankan di sini:

${BUILD_DIR%Build/*}/SourcePackages/checkouts/firebase-ios-sdk/Crashlytics/run

Opsi lain untuk mengupload simbol adalah menggunakan skrip upload-symbols. Tempatkan skrip di subdirektori file project Anda (misalnya scripts/upload-symbols), lalu pastikan skrip tersebut dapat dijalankan:

chmod +x scripts/upload-symbols

Skrip ini dapat digunakan untuk mengupload file dSYM secara manual. Untuk catatan penggunaan dan petunjuk tambahan untuk skrip, jalankan upload-symbols tanpa parameter apa pun.