Google 致力于为黑人社区推动种族平等。查看具体举措
ترجمت واجهة Cloud Translation API‏ هذه الصفحة.
Switch to English

تشغيل البريد الإلكتروني

Firebase
من صنع Firebase

يؤلف ويرسل بريدًا إلكترونيًا استنادًا إلى محتويات مستند مكتوب إلى مجموعة Cloud Firestore محددة.

كيف يعمل هذا الامتداد

استخدم هذا الامتداد لعرض وإرسال رسائل البريد الإلكتروني التي تحتوي على معلومات من المستندات المضافة إلى مجموعة Cloud Firestore محددة.

تؤدي إضافة مستند إلى تشغيل هذا الامتداد لإرسال بريد إلكتروني مبني من حقول المستند. تحدد حقول المستوى الأعلى للمستند مرسل البريد الإلكتروني والمستلمين ، بما to ذلك خيارات to و cc و bcc (كل معرّفات UID تدعم). يحدد حقل message المستند عناصر البريد الإلكتروني الأخرى ، مثل سطر الموضوع ونص البريد الإلكتروني (إما نص عادي أو HTML)

في ما يلي مثال أساسي على كتابة المستند الذي سيؤدي إلى تشغيل هذا الامتداد:

60585 ثيب 60

يمكنك أيضًا تكوين هذا الامتداد اختياريًا لعرض رسائل البريد الإلكتروني باستخدام قوالب المقود . كل قالب هو مستند مخزن في مجموعة Cloud Firestore.

عند تكوين هذا الامتداد ، ستحتاج إلى توفير بيانات اعتماد SMTP لتسليم البريد . لاحظ أن هذا الامتداد مخصص للاستخدام مع مزودي خدمة البريد الإلكتروني المجمعة ، مثل SendGrid و Mailgun وما إلى ذلك.

الإعداد الإضافي

قبل تثبيت هذا الامتداد ، تأكد من إعداد قاعدة بيانات Cloud Firestore في مشروع Firebase.

الفواتير

لتثبيت ملحق ، يجب أن يكون مشروعك على خطة Blaze (الدفع الفوري)

  • سيتم تحصيل مبلغ صغير منك (عادةً حوالي 0.01 دولار شهريًا) لموارد Firebase المطلوبة بواسطة هذا الامتداد (حتى إذا لم يتم استخدامه).
  • يستخدم هذا الامتداد خدمات Firebase و Google Cloud Platform الأخرى ، والتي لها رسوم مرتبطة إذا تجاوزت المستوى المجاني للخدمة:
  • سحابة Firestore
  • وظائف السحابة (وقت تشغيل Node.js 10+. راجع الأسئلة الشائعة )

يتطلب استخدام هذا الامتداد أيضًا أن يكون لديك بيانات اعتماد SMTP لتسليم البريد. أنت مسؤول عن أي تكاليف مرتبطة باستخدامك لمزود SMTP الخاص بك.

كيفية تثبيت هذا الامتداد

باستخدام وحدة تحكم Firebase

لتثبيت الإضافات وإدارتها ، يمكنك استخدام وحدة تحكم Firebase.

التثبيت باستخدام وحدة التحكم

استخدام Firebase CLI

لتثبيت الإضافات وإدارتها ، يمكنك أيضًا استخدام Firebase CLI:

الخطوة 1: قم بتشغيل الأمر npm التالي لتثبيت CLI أو التحديث إلى أحدث إصدار من CLI.

npm install -g firebase-tools
لا يعمل؟ ألق نظرة على مرجع Firebase CLI أو قم بتغيير أذونات npm الخاصة بك.

الخطوة 2: قم بتثبيت هذا الامتداد عن طريق تشغيل الأمر التالي

firebase ext:install firestore-send-email --project=projectId_or_alias
يدعم
سحابة Firestore
مؤلف
رخصة
اباتشي 2.0
الإصدار
0.1.6