与 Mailchimp 同步

Firebase
Made by Firebase

将来自 Firebase 身份验证的新用户添加到特定的 Mailchimp 受众群体中。

此扩展程序的运作方式

使用此扩展程序将新用户添加到现有 Mailchimp 受众群体。

此扩展程序将每位新用户的电子邮件地址添加到您指定的 Mailchimp 受众群体。另外,如果用户删除了他们在您的应用中的用户帐号,则此扩展程序会将用户从 Mailchimp 受众群体中移除。

注意:要使用此扩展,您需要使用 Firebase 身份验证功能来管理用户。

此扩展程序使用 Mailchimp,因此在安装此扩展程序时,您需要提供 Mailchimp API 密钥和受众群体 ID。

额外设置

确保您已经对 Firebase 身份验证进行了设置以管理您的用户。

在安装此扩展程序之前,您还必须具有 Mailchimp 帐号。

结算

此扩展程序要用到其他 Firebase 或 Google Cloud Platform 服务,而这些服务可能会产生相关的费用:

  • Firebase 实时数据库
  • Cloud Functions

在您使用 Firebase Extensions 时,仅需为所使用的基本资源付费。只有此扩展程序使用的服务(例如,调用 Google Cloud Platform API 或向非 Google 服务发出出站网络请求)需要付费层级方案时,此扩展程序才需要付费层级结算方案。所有 Firebase 服务均提供免费用量层级。详细了解 Firebase 结算。

使用此扩展程序时,您还需要具有 Mailchimp 帐号。您需要负责承担与使用 Mailchimp 相关的任何费用。

如何安装此扩展程序

使用 Firebase 控制台

要安装和管理扩展程序,您可以使用 Firebase 控制台。

使用控制台安装

使用 Firebase CLI

要安装和管理扩展程序,您还可以使用 Firebase CLI:

步骤 1:运行以下 npm 命令来安装 CLI 或将 CLI 更新到最新版本。

npm install -g firebase-tools
不能运行?请参阅 Firebase CLI 参考文档或者更改您的 npm 权限

步骤 2:运行以下命令来安装此扩展程序

firebase ext:install auth-mailchimp-sync --project=projectId_or_alias

必须使用 Blaze 方案

作者
许可
Apache-2.0
版本
0.1.0